Fail to build using jhbuild due the lacks of gtk+-3.0 >= 3.0.8

Braiam Miguel Peguero Novo's picture

Forums: 

Hi there,

Im not suscribed to the mail-list so, include me in the "to:" Smile

I'm compiling gnome3-desktop, in my ubuntu desktop 11.04, I followed the
jhbuild manual about building gnome3, I also have done the complete
compilation, but have to drop it, due the fact that it was installed on
my home dir, so I tried to compile it again using the /opt/gnome dir,
but now i found myself into this crappy error about not found gtk+-3.0
>= 3.0.8, but I already done the build (about 5 times), cleaning the
build dir, downloading the source again, wipe out all and try again, but
I don't get this work in any of the modules that depends on gtk+3. So
can someone point me in the right direction?

All that can be requested:
jhbuild version: update from the git repository
modules that fail: all that depends on gtk+3, glib-2.0, and other that I
may doesn't know.
Running on a Ubuntu Natty Narwalh 11.04, all up-to-date
gtk+3 on the /opt/gnome dir: 3.1.5
gtk+3 on wide system (a bad idea to use that ik): 3.0.8-0ubuntu1

Because, there are anothers build-dep not meeting, Im pretty sure that
is about a path misconfigurated, so if anyone can said me the correct
way to set it up in jhbuild, I'll be pleased.

Fail to build using jhbuild due the lacks of gtk+-3.0 >= 3.0.8

Camaleón's picture

On Sun, 29 May 2011 04:55:43 -0400, Braiam Miguel Peguero Novo wrote:

> Im not suscribed to the mail-list so, include me in the "to:" Smile

I can't, so you'll have to read the mailing list archive ;-(

> I'm compiling gnome3-desktop, in my ubuntu desktop 11.04,

(...)

Wait... Compiling gnome3-desktop under Ubuntu? Then you better ask in the
Ubuntu mailing list or forums, there you will get accurate replies for
your distribution and your problem.

Additional tip: include the error you are getting so people can have a
better idea of the issue.

Greetings,

RE: Fail to build using jhbuild due the lacks of gtk+-3.0 >= 3.0

Wolfe, Robert \(Debian\)'s picture

Braiam, have you tried asking this same question on the Ubuntu mailing lists? This is the debian-user list (not that that should make that much of a difference, just a thought).

From: Braiam Miguel Peguero Novo [mailto:braiamp@gmail.com]
Sent: Sunday, May 29, 2011 4:56 AM
To: debian-user@lists.debian.org
Subject: Fail to build using jhbuild due the lacks of gtk+-3.0 >= 3.0.8

Hi there,

Im not suscribed to the mail-list so, include me in the "to:" Smile

I'm compiling gnome3-desktop, in my ubuntu desktop 11.04, I followed the jhbuild manual about building gnome3, I also have done the complete compilation, but have to drop it, due the fact that it was installed on my home dir, so I tried to compile it again using the /opt/gnome dir, but now i found myself into this crappy error about not found gtk+-3.0 >= 3.0.8, but I already done the build (about 5 times), cleaning the build dir, downloading the source again, wipe out all and try again, but I don't get this work in any of the modules that depends on gtk+3. So can someone point me in the right direction?

All that can be requested:
jhbuild version: update from the git repository
modules that fail: all that depends on gtk+3, glib-2.0, and other that I may doesn't know.
Running on a Ubuntu Natty Narwalh 11.04, all up-to-date
gtk+3 on the /opt/gnome dir: 3.1.5
gtk+3 on wide system (a bad idea to use that ik): 3.0.8-0ubuntu1

Because, there are anothers build-dep not meeting, Im pretty sure that is about a path misconfigurated, so if anyone can said me the correct way to set it up in jhbuild, I'll be pleased.