The following packages have unmet dependencies nightmare

oneduality's picture

Forums: 

I inherited a server that I'm maintaining, it's unfortunately a production server hosting many sites .. I need to hopefully get apt back to working condition if possible.. without breaking the server in the process ( breaking as in interrupting services )

Any attempt to install anything via apt results in the following:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  davfs2: Depends: libneon27 (>= 0.28.2) but it is not going to be installed
  libboost-program-options1.46.1: Depends: libstdc++6 (>= 4.4.0) but 4.3.2-1.1 is to be installed
  libqpidcommon2: Depends: libstdc++6 (>= 4.6) but 4.3.2-1.1 is to be installed
  libqpidtypes1: Depends: libstdc++6 (>= 4.6) but 4.3.2-1.1 is to be installed
  libsslcommon2: Depends: libstdc++6 (>= 4.4.0) but 4.3.2-1.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The contents of /etc/apt/sources.list is as follows:

#
# deb cdrom:[Debian GNU/Linux testing _Lenny_ - Official Snapshot amd64 NETINST Binary-1 20081230-14:49]/ lenny main
#deb cdrom:[Debian GNU/Linux testing _Lenny_ - Official Snapshot amd64 NETINST Binary-1 20081230-14:49]/ lenny main
deb http://ftp.us.debian.org/debian/ lenny main
deb-src http://ftp.us.debian.org/debian/ lenny main
deb http://security.debian.org/ lenny/updates main
deb-src http://security.debian.org/ lenny/updates main
#deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
#deb http://security.debian.org/ lenny/updates main contrib non-free
#deb-src http://security.debian.org/ lenny/updates main contrib non-free
#deb http://download.webmin.com/download/repository sarge contrib
## PHP 5.3
#deb http://packages.dotdeb.org stable all
#deb-src http://packages.dotdeb.org stable all
## Debian sources
#deb http://ftp.us.debian.org/debian testing main contrib non-free
#
#deb http://ftp.us.debian.org/debian lenny main contrib non-free
#deb http://archives.dotdeb.org/ lenny php5
#deb http://packages.dotdeb.org stable all
#deb-src http://packages.dotdeb.org stable all

unable to upgrade from squeeze to wheezy(testing)

rupeshforu3's picture

recently I have installed debian squeeze6.0.6 on amd64 fx 4100 machine.Then I issued the command apt-get upgrade which was failed
and given error message as unmet dependencies. Now when I issue the command apt-get dist-upgrade again the same error messages are appearing. I have googled a lot on how to solve unmet dependencies but none worked. Please help me.