Icedove can't start

pch0317's picture

Forums: 

Hi,

Icedove can't start. When I start it from terminal I get:
/usr/lib/icedove/icedove-bin: symbol lookup error:
/usr/lib/icedove/components/libmailcomps.so: undefined symbol:
NS_CStringContainerInit2

It's happen on Linux Debian testing amd64. It is fresh install.

How to repair this.

Thanks

Icedove can't start

Johan Grönqvist's picture

2011-05-28 14:44, pch0317 skrev:
> Icedove can't start. When I start it from terminal I get:
> /usr/lib/icedove/icedove-bin: symbol lookup error:
> /usr/lib/icedove/components/libmailcomps.so: undefined symbol:
> NS_CStringContainerInit2
>

There are bugs reported where icedove has problems with undefined
symbols (bugs 626812 and 617759). None of them with the same symbol as
you report.

Both bug reports suggest starting icedove as

LD_BIND_NOW=1 icedove

from the command line, and see if that helps. None of the two bugs are
marked as resolved.

Hope it helps,

/ johan

Icedove can't start

pch0317's picture

On 28/05/11 14:57, Johan Grönqvist wrote:
> 2011-05-28 14:44, pch0317 skrev:
>> Icedove can't start. When I start it from terminal I get:
>> /usr/lib/icedove/icedove-bin: symbol lookup error:
>> /usr/lib/icedove/components/libmailcomps.so: undefined symbol:
>> NS_CStringContainerInit2
>>
>
> There are bugs reported where icedove has problems with undefined
> symbols (bugs 626812 and 617759). None of them with the same symbol as
> you report.
>
> Both bug reports suggest starting icedove as
>
> LD_BIND_NOW=1 icedove
>
> from the command line, and see if that helps. None of the two bugs are
> marked as resolved.
>
>
> Hope it helps,
>
> / johan
>
>
Thanks,
it helps.