openstack: installing glance, greenlet problem

mr_tigi's picture

Forums: 

Hi,

i'm using debian (7.0 a.k.a. wheezy). and was following your guide. At the part of installing the image service i ran into a problem. When trying to install glance it gave me an error, namely that it depends on glance-api and glance-registry, so i tried installing glance-common. Turns out this depends on python-glance so i tried installing that, and that's where the problem starts. This package depends on python-greenlet, which is installed but the error said: "depends: python-greenlet (>=0.3.2) but 0.3.1-2.5 is to be installed". now i've tried many things, apt-get update, upgrade, pip install greenlet, installing the dev version of greenlet and then some more minor things i've forgotten at the moment, but nothing seems to work. Does anyone have an idea how to fix this problem ?

I would be most grateful.

Glance install

IntnsRed's picture

Debian, and other GNU/Linux distributions, have the concept of "dependencies". One software package may "depend" (require) another software package. Thus, to install Package G, you will have to install Packages A, B, C, D, E and F first. Typically these dependencies are library packages that provide some specific functions for the program you want to install.

Glance has about 2 dozen dependencies.

When using apt-get, it will install all of these dependencies automatically for you.

What I'd suggest is that at this point is to use a package manager program to get this sorted out. Debian has multiple package managers. Its default, "aptitude", is a text-mode package manager that can work over a remote ssh (secure shell) terminal link. A popular graphical package manager is "synaptic". (Do an "apt-get install synaptic" to install it.)

Your first task should be to make sure your system is in a stable, working and updated state.

This can be done by running "apt-get update ; apt-get dselect-upgrade"; that should get your system up to date. Or by using synaptic, just click on "Reload" (to update the package database), then click on "Mark All Upgrades" (to select any updated packages), and finally click on "Apply" to download and update any software.

Once your system is updated, you should be able to just do an "apt-get install glance" or use synaptic to mark glance for installation and then clicking on Apply.

The error message you're getting about versions of python-greenlet is that glance (or python-glance?) depends on one specific version, but apt-get has been told to install an older version (a version downgrade). 0.3.1-2.5 is the current latest version of python-greenlet in Debian Wheezy; so you must have used a non-Debian source to install a newer version of glance. (Did you install glance or python-glance from backports.org, from a download somewhere, or from some Ubuntu source?) Mixing and matching versions like this is, as you discovered, a recipe for potential headaches -- especially with something like glance that has so many dependencies.