Major Dependency Problems - Trying to clean up my system, please help!

muggles's picture

Forums: 

Hi All,

When i attempt to install a package i receive a large list of dependency issues.

E.g. sudo apt-get install nodejs produces the following:

Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
gksu:i386 : Depends: sudo:i386
             Recommends: gnome-keyring:i386 but it is not going to be installed
libcairo2:i386 : Depends: libpixman-1-0:i386 (>= 0.30.0) but it is not going to be installed
                  Depends: libxcb-render0:i386 but it is not going to be installed
                  Depends: libxcb-shm0:i386 but it is not going to be installed
libgconf-2-4:i386 : Depends: libdbus-glib-1-2:i386 (>= 0.78) but it is not going to be installed
libgdk-pixbuf2.0-0:i386 : Depends: libjasper1:i386 but it is not going to be installed
                           Depends: libtiff5:i386 (>= 4.0.3) but it is not going to be installed
libgksu2-0:i386 : Depends: libgtop2-7:i386 (>= 2.22.3) but it is not going to be installed
                   Depends: xauth:i386 but it is not going to be installed
                   Recommends: sudo:i386
libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.6.0) but it is not going to be installed
                    Depends: libxcomposite1:i386 (>= 1:0.3-1) but it is not going to be installed
libpango-1.0-0:i386 : Depends: libthai0:i386 (>= 0.1.12) but it is not going to be installed
libpangoft2-1.0-0:i386 : Depends: libharfbuzz0b:i386 (>= 0.9.9) but it is not going to be installed
libstartup-notification0:i386 : Depends: libxcb-util0:i386 (>= 0.3.8) but it is not going to be installed
nodejs : Depends: libc-ares2 (>= 1.8.0) but it is not going to be installed
          Depends: libv8-3.14.5 but it is not going to be installed
wine-development : Depends: wine64-development (>= 1.7.29-4) but it is not going to be installed or
                             wine32-development (>= 1.7.29-4)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The problems all started when i attempted to install Guitar Pro. When i ran dpkg -i guitarpro.deb it wanted to do the following, so i cancelled it, but my system is now in a complete mess stage:

The following packages will be REMOVED:
  gksu:i386 libgksu2-0:i386 sudo task-desktop task-gnome-desktop xinit xorg

Any help would be much appreciated.
Thanks in advance!

Thanks! That probably would

muggles's picture

Thanks! That probably would have worked if i hadn't screwed up my system beforehand but i've made some progress.
When i run:
sudo dpkg -i --force-architecture gp6-full-linux-demo-r11683-modified.deb
I get the following:

(Reading database ... 219497 files and directories currently installed.)
Preparing to unpack gp6-full-linux-demo-r11683-modified.deb ...
Unpacking guitarpro6 (6.1.8) over (6.1.8) ...
dpkg: dependency problems prevent configuration of guitarpro6:
guitarpro6 depends on libportaudio0.
guitarpro6 depends on libssl0.9.8.

dpkg: error processing package guitarpro6 (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
guitarpro6

Any ideas?

You say:

arochester's picture

You say:
"dpkg: dependency problems prevent configuration of guitarpro6:
guitarpro6 depends on libportaudio0.
guitarpro6 depends on libssl0.9.8."

That is covered by #3 in the link. You may have installed the libraries, but did you update/upgrade first to bring them into effect?
(As Root)
apt-get update
apt-get upgrade
apt-get dist-upgrade

Then try again

No luck unfortunately:sudo

muggles's picture

No luck unfortunately:
sudo apt-get update [OK]
sudo apt-get upgrade [FAILS]

Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
gksu:i386 : Depends: sudo:i386
             Recommends: gnome-keyring:i386 but it is not installed
guitarpro6:i386 : Depends: libportaudio0:i386 but it is not installed
                   Depends: libssl0.9.8:i386 but it is not installed
libcairo2:i386 : Depends: libpixman-1-0:i386 (>= 0.30.0) but it is not installed
                  Depends: libxcb-render0:i386 but it is not installed
                  Depends: libxcb-shm0:i386 but it is not installed
libgconf-2-4:i386 : Depends: libdbus-glib-1-2:i386 (>= 0.78) but it is not installed
libgdk-pixbuf2.0-0:i386 : Depends: libjasper1:i386 but it is not installed
                           Depends: libtiff5:i386 (>= 4.0.3) but it is not installed
libgksu2-0:i386 : Depends: libgtop2-7:i386 (>= 2.22.3) but it is not installed
                   Depends: xauth:i386 but it is not installed
                   Recommends: sudo:i386
libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.6.0) but it is not installed
                    Depends: libxcomposite1:i386 (>= 1:0.3-1) but it is not installed
libpango-1.0-0:i386 : Depends: libthai0:i386 (>= 0.1.12) but it is not installed
libpangoft2-1.0-0:i386 : Depends: libharfbuzz0b:i386 (>= 0.9.9) but it is not installed
libstartup-notification0:i386 : Depends: libxcb-util0:i386 (>= 0.3.8) but it is not installed
wine-development : Depends: wine64-development (>= 1.7.29-4) but it is not installed or
                             wine32-development (>= 1.7.29-4)
E: Unmet dependencies. Try using -f.

sudo apt-get dist-upgrade [FAILS]

Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
gksu:i386 : Depends: sudo:i386
             Recommends: gnome-keyring:i386 but it is not installed
guitarpro6:i386 : Depends: libportaudio0:i386 but it is not installed
                   Depends: libssl0.9.8:i386 but it is not installed
libcairo2:i386 : Depends: libpixman-1-0:i386 (>= 0.30.0) but it is not installed
                  Depends: libxcb-render0:i386 but it is not installed
                  Depends: libxcb-shm0:i386 but it is not installed
libgconf-2-4:i386 : Depends: libdbus-glib-1-2:i386 (>= 0.78) but it is not installed
libgdk-pixbuf2.0-0:i386 : Depends: libjasper1:i386 but it is not installed
                           Depends: libtiff5:i386 (>= 4.0.3) but it is not installed
libgksu2-0:i386 : Depends: libgtop2-7:i386 (>= 2.22.3) but it is not installed
                   Depends: xauth:i386 but it is not installed
                   Recommends: sudo:i386
libgtk2.0-0:i386 : Depends: libcups2:i386 (>= 1.6.0) but it is not installed
                    Depends: libxcomposite1:i386 (>= 1:0.3-1) but it is not installed
libpango-1.0-0:i386 : Depends: libthai0:i386 (>= 0.1.12) but it is not installed
libpangoft2-1.0-0:i386 : Depends: libharfbuzz0b:i386 (>= 0.9.9) but it is not installed
libstartup-notification0:i386 : Depends: libxcb-util0:i386 (>= 0.3.8) but it is not installed
wine-development : Depends: wine64-development (>= 1.7.29-4) but it is not installed or
                             wine32-development (>= 1.7.29-4)
E: Unmet dependencies. Try using -f.

Could all of the other unmet dependencies be preventing it from installing?

I think i'm fixed!

muggles's picture

I think i'm fixed!
I did the following:
sudo aptitude remove gcc-4.9-base:i386
(i had to select "n" to the first 2 solutions and "y" to the 3rd solution which involved installing a stack of i386 packages)
sudo apt-get update
sudo apt-get upgrade
sudo apt-get clean
sudo updatedb
sudo apt-get install gksu

Success!

muggles's picture

Success!
Guitar pro is now installed too! Thanks for your help!